2018-10-21         Regan

Gradle Sync failed: Premature end of Content-length delimited message body (Expected: 27633912;received : 12844960)

I have installed Android Studio 3.1.4 and the Gradle (Version 4.4) is not synchronizing; it says: Gradle Sync failed: Premature end of Content-length delimited message body (Expected: 27633912;received : 12844960)Build.Gradle This was happening because of "unstable" internet connection. I used a stable connection and gradle synchronized successfully. [XXX]

 android-studio                     1 answers                     98 view
 2018-10-21         Diana

Connection to localhost on the Android emulator

I can not connect to localhost in the android emulator.The API I have built in Net Core 2 and running in VS2017 (Windows 10)adress http://localhost:50069/api/valuesWhat I checked and does not work (does not react):http://10.0.2.2:50069/api/valueshttp://ip:50069/api/values (ip -> ipv4 address from ipconfig)http://127.0.0.1:50069/api/valueshttp://0.0.0.0:50069/api/valuesI've already checked out all the advice on what was on the net and nothing I had same problem with ASP.net. I fixed this problem by updating IP binding.Note: Make sure to keep backup of your project before ...

 android-studio                     1 answers                     23 view
 2018-10-21         Hardy

android studio debug: can not resolve symbols in dependency jar

Android studio debug:An android lib project that uses a java library jar which has/package/Foo.java/package/Bar.javaIn the android library project code: Bar.someMethod(...)The Bar class can not be resolved. So I can not step into the class. Other classes in the dependency jar can be resolved without problems.Tried the followings, but no luck.1. Invalidate and Restart2. Delete .idea and *.iml files3. close project and re-open4. gradle clean and rebuild One posible case for that error can be that this 'Bar class' be referenced in another library first and so the main proje...

 android-studio                     1 answers                     36 view
 2018-10-21         Warner

Multiple android studio on Mac

My system is MacBook, can I have one version from android studio stable and android studio beta on my system ?I have android studio 3.1.4 stable on my system now.Problem: I need to android studio 3.2 beta now.I need to stable and Beta, I need to beta and to stable often. Yes... just download them and put the different versions in your applications folder. I'm currently running 3.1.4 stable, 3.2 beta 5, and 3.3 canary 5. The beta and canary versions will have a yellow icon. [XXX]

 android-studio                     1 answers                     95 view
 2018-10-21         Troy

All letters R in construcnions R.id.name became red

After connection FireBase all letters R in constructions R.id.name became red. Task clean project doesnt help. Deleting directories build/ doesnt help also. in log is written error: attribute 'e.android.myapp:adSize' not found.Please, advice me, how can i solve this problem. R is the main Resource.java which keeps a map of all allocations whichever you make in your app. It is deleted by its own if something is wrong in any of you .xml files, whether it is drawable, or layout, or any other res files.the attribute adSize is not allowed in whichever layout tag you are tryin...

 android-studio                     1 answers                     92 view
 2018-10-21         Harvey

Android Studio will not debug (only builds) since trying to generate a signed apk

AS builds the debug APK just fine, but will not load to the phone and debug on the phoneHere is the output on a debug [assembleDebug] run:7:52:18 PM: Executing task 'assembleDebug'...Executing tasks: [assembleDebug]Configuration on demand is an incubating feature.:app:preBuild UP-TO-DATE:app:preDebugBuild UP-TO-DATE:app:compileDebugAidl UP-TO-DATE:app:compileDebugRenderscript UP-TO-DATE:app:checkDebugManifest UP-TO-DATE:app:generateDebugBuildConfig UP-TO-DATE:app:prepareLintJar UP-TO-DATE:app:mainApkListPersistenceDebug UP-TO-DATE:app:generateDebugResValues UP-TO-DATE:app:g...

 android-studio                     1 answers                     72 view
 2018-10-21         Harry

How do I import dependencies after declaring them in build.gradle?

I am just starting to work on android studio and beginning to explore the world of Gradle. So I created a project in Android Studio, opened up build.gradle and added dependencies like the below:dependencies { compile 'com.android.support:support-v4:19.0.1' compile 'com.android.support:appcompat-v7:19.0.1' compile 'com.squareup.retrofit:retrofit:1.3.0' compile 'com.jakewharton.timber:timber:2.1.0'}After this I notice a tip popping up on build.gradle which says: You can configure Gradle wrapper to use distribution with sources. It will provide IDE with Gradle A...

 android-studio                     2 answers                     27 view
 2018-10-21         Frederica

how do i display an image on text view using ibm watson assistant?

I have created a chat application using IBM Watson assistant and android studio. The problem is I'm having difficulties with displaying images in a text view.I have added the image as URL Image. It is displaying and working in the try console as well. See the screenshot below.But when I try displaying it in my android app it won't show up...Following is my XML, display code for responses, Message message = messageArrayList.get(position); message.setMessage(message.getMessage());((ViewHolder) holder).message.setText(Html.fromHtml(message.getMessage())); <TextView ...

 android-studio                     1 answers                     46 view
 2018-10-21         Harry

appcompat-v7:28.0.0-beta01 Broke after update

I am beginner in Android studio and installed it yesterday. Then I created a empty project that worked just fine. Today I had to update and now I am fighting with that error message:As you can see I already included the Examples. Any ideas how I can fix that?Here the full app.gradleapply plugin: 'com.android.application'apply plugin: 'kotlin-android'apply plugin: 'kotlin-android-extensions'android { compileSdkVersion 28 defaultConfig { applicationId "at.sumser.fateandlove" minSdkVersion 15 targetSdkVersion 28 versionCode 1 versionNam...

 android-studio                     1 answers                     63 view
 2018-10-21         Ansel

java.lang.ClassNotFoundException: android.view.View$OnUnhandledKeyEventListener

when i try to add the image view to the layout editor of android studio it is not showing up and also it is showing some errors Javajava.lang.ClassNotFoundException: android.view.View$OnUnhandledKeyEventListener at org.jetbrains.android.uipreview.ModuleClassLoader.load(ModuleClassLoader.java:180) at com.android.tools.idea.rendering.RenderClassLoader.findClass(RenderClassLoader.java:61) at org.jetbrains.android.uipreview.ModuleClassLoader.findClass(ModuleClassLoader.java:118) at java.lang.ClassLoader.loadClass(ClassLoader.java:424) at java.lang.ClassLoader.l...

 android-studio                     1 answers                     95 view
 2018-10-21         Wilbur

In gmail app, calendar and contacts, can be opened seperately. How we can open another app from main app

I was using gmail, I found that gmail app can access google calendar and contacts under google apps tag in navigation drawer. My point is, how we can access another app. Please help me. I have made two separate apps and I want to give such link in my third app.Thanks for the help... Friends,Recently, on some google search I found thatprivate String packge_name = "com.android.calculator2"; private String class_name = "com.android.calculator2.Calculator"; private Button bt;Then put the code @Overrideprotected void onCreate(Bundle savedInstanceState) { super.onC...

 android-studio                     1 answers                     72 view
 2018-10-22         Nicola

Lint errors after migration to AndroidX:

After migration/refactor to AndroidX (using the migration tool in Android Studio 3.2 RC2), I get a huge set of the following type of Lint errors:participant_menu.xml:9: Error: Should use android:showAsAction when not using the appcompat library [AppCompatResource] app:showAsAction="never" />I'm confused; I guess this is an error in Lint related to the migration to AndroidX. Am I correct, or should I switch back to the android namespace?Note: my minSDK is set to API 16. Should use android:showAsAction when not using the appcompat library [AppCompatResource]...

 android-studio                     1 answers                     30 view
 2018-10-22         Dana

CoordinatorLayout does not display with targetSdkVersion 28 in AndroidStudio 3.1.4

I'm using the latest version of android studio (3.1.4), along with latest SDK version (28).The layout does not get rendered in the design tab, I'm using coordinator layout.styles.xml:<resources> <style name="AppTheme" parent="Base.Theme.AppCompat.Light.DarkActionBar"> <!-- Customize your theme here. --> <item name="colorPrimary">@color/colorPrimary</item> <item name="colorPrimaryDark">@color/colorPrimaryDark</item> <item name="colorAccent">@color/colorAccent</item> </style></re...

 android-studio                     1 answers                     48 view
 2018-10-22         Asa

Flutter create command was unsuccessful error

I'm creating a new flutter project in Android studio. I give the project a name and choose Flutter application. I then clicked finish and then noting happened.Android studio says that"Flutter create command was unsuccessful"When I navigate to command directory using file explorer, I new folder is created with the project name I've given but it is empty.Please help. I've solution to this problem now.After running flutter doctor --android-licenses I got to know that I need to update my sdkManager.Then I went to that directory usingcd C:\Users\[user-name]\AppData\Local\Andr...

 android-studio                     1 answers                     91 view
 2018-10-22         Darlene

Android Studio: unable to find valid certification path to requested target using Proxy

I am under enterprise network and I have tried adding proxies into android studio as well as in gradle but still I am facing this issue of certificate path.I have also tried adding jcenter cert to studio but it does not help either.Here are the logs: Caused by: org.gradle.internal.resource.transport.http.HttpRequestException: Could not GET 'https://dl.google.com/dl/a ndroid/maven2/com/android/tools/build/gradle/3.1.4/gradle-3.1.4.pom'.at org.gradle.internal.resource.transport.http.HttpClientHelper.performRequest(HttpClientHelper.java:96)at org.gradle.internal.resource.tra...

 android-studio                     1 answers                     1 view
 2018-10-22         Maxwell

How to disable code inspection errors in README.md file in Android Studio

In my GitHub README.md file, which is in the root of my Android project, I have code snippets like the following ones:```xmlandroid:windowSoftInputMode="stateHidden"``````javaMongolToast.makeText(getApplicationContext(), "ᠰᠠᠢᠨ ᠪᠠᠢᠨ᠎ᠠ ᠤᠤ︖", MongolToast.LENGTH_LONG).show();```However, in Android Studio these code snippets give errorsI don't want to be warned of supposed code errors in the README file. How do I disable all errors here?Notes:I know how to suppress inspections normally in code with @SuppressLint or going into settings and unchecking the lint inspection. I don't ...

 android-studio                     2 answers                     4 view

Page 1 of 48  |  Show More Pages:  Top Prev Next Last