asked    Sigrid     2018-07-24       android       230 view        1 Answer

[SOLVED] Could not download auto-value.jar (com.google.auto.value:auto-value:1.5.2): No cached version available for offline mode

I have almost tried everything I know, but still as soon as I update my Android studio to the latest version it shows this error.What should I do?

The gradle.build is:

buildscript {

    repositories {
        google()
        jcenter()

    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.2'


        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        google()
        jcenter()
        maven{
            url "https://maven.google.com"
        }
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

  1 Answer  

        answered    Mandel     2018-07-24      

I faced the same problem today. I solved it by downloading the auto-value.jar file manually. Then I added the jar file to the libs folder. After doing so I synced the gradle files.

Here are details on how to add a jar file into Android Studio.

All the best.





Your Answer





 2018-07-24         John

Gradle implementation not importing gradle module into gradle project

I have created two gradle, Let's say Libary-Project and TestProject in the same eclipse workspace folder.Below are the build.gradle and settings.gradle for Library Project. Library Project build.gradle/* * This build file was generated by the Gradle 'init' task. * * This generated file contains a sample Java Library project to get you started. * For more details take a look at the Java Libraries chapter in the Gradle * user guide available at https://docs.gradle.org/3.5/userguide/java_library_plugin.html */// Apply the java-library plugin to add support for Java Libraryappl...
 java                     1 answers                     42 view
 2018-07-24         Joan

Get latest snapshot version from Maven Repository in Gradle

I have project which using Gradle to publish our SNAPSHOT artifact's to remote Maven Repository.When I publish to Maven, time stamp and build number is getting appended to Jar name. And I am trying to download the latest version ie myjar-1.6.0-20170926.190543-10.jar from one of other project. I am not able to download until unless, I remove it from my .gradle or restart my work space.myjar-1.6.0-20170926.162756-7.jar myjar-1.6.0-20170926.162756-7.jar.md5 myjar-1.6.0-20170926.162756-7.jar.sha1 myjar-1.6.0-20170926.162756-7.pom myjar-1.6.0-20170926.162756-...
 java                     1 answers                     42 view
 2018-07-24         Winifred

Generated Gradle build files from Eclipse, getting error: Gradle version 1.10 is required

I generated a Gradle build file from an Eclipse project, then ran gradle build in the source root dir, which generated the following error:FAILURE: Build failed with an exception.* Where:Build file '/home/me/src/myproject/build.gradle' line: 11* What went wrong:A problem occurred evaluating project ':src:myproject'.> Failed to apply plugin [id 'com.android.application'] > Gradle version 1.10 is required. Current version is 2.10. If using the gradle wrapper, try editing the distributionUrl in /home/me/src/myproject/gradle/wrapper/gradle-wrapper.properties to gradle-1...
 java                     1 answers                     44 view